
Adobe Fireworks CS6 and Adobe Dreamweaver CS6 Project 3 guide
How to create interactive navigation
There are several options for creating interactive navigation for your web pages: You can easily create:

• graphical buttons and navigation bars in Fireworks, and import them into Dreamweaver. 

• image-based, or HTML, pop-up menus in Fireworks, and place them in a Dreamweaver file.

• rollover images that add visual interest and interaction by using Dreamweaver.

Advanced users may consider using Fireworks to create CSS-based interactive navigation. You can use the CSS 
Properties panel to extract complex CSS3 properties for buttons, such as text, border radius, and gradients..

Creating buttons and navigation bars in Fireworks
Fireworks CS6 enables you to design the look and functionality of buttons, including links and rollover features. 
After you export these buttons from Fireworks, you can import them into Dreamweaver CS6.

Building buttons

In the following steps, you create a button for export into Dreamweaver.

To build a button:

1. Start Fireworks. 

2. Create a new document. 

3. Type 200 pixels for Width and 200 pixels for Height. Type 72 pixels/inch for Resolution.

Note: At the end of this exercise, you will trim the canvas to fit the button. 

4. Save the document in the images folder of your Dreamweaver website.

5. Select Edit > Insert > New Button.

The button editor opens and the Properties panel displays button properties (Figure 1).

Figure 1 Button Properties panel

6. Deselect the Enable option for 9-Slice Scaling Guides in the Properties panel. (To learn about 9-Slice Scaling 
Guides, select Help > Fireworks Help).

Buttons contain four states:

• Up (button untouched)

• Over (pointer over button)

• Down (button being clicked)

• Over While Down (pointer over while 
button held down)

You can view each state by selecting it in the State pop-up menu in the Properties panel (Figure 1). The current 
state of the new button is Up, as shown in the Properties panel.

State pop-up menu9-slice scaling guides Enable/Disable option
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7. Use the Rectangle tool or the Ellipse tool from the Tools panel to draw a shape for the Up state. Make the 
dimensions of the shape fit the size of your navigation bar.

8. To add depth to the button, click the Add Live Filters button in the Properties panel (the plus sign next to Filters), 
and then select a bevel option from the pop-up menu:

• Bevel and Emboss > Inner Bevel

• Bevel and Emboss > Outer Bevel

9. Using the Properties panel, add color to the button. 

10. Use the Text tool to add text to the button, and center-align the text. 

The color and text of the button should match the color and font design of your page.

11. Confirm the Smart Guides are visible and active. If not, select View > Smart Guides, and then select Show Smart 
Guides and Snap To Smart Guides.

12. Select the Pointer tool. 

13. Drag the text block until the horizontal and vertical Smart Guides appear so that the text is centered over the 
shape (Figure 2).

Figure 2 Smart Guides

14. Select Window > Object & Layout > Align (Windows) or Window > Align (Mac OS) to open the Align panel.

15. Click the button at the top of the panel, if necessary, until the label Relative To Canvas is visible (Figure 3). 

Figure 3 Align Panel

16. Use the Pointer tool and shift-click to select both the button and the text.

17. Click the Align Horizontal Center and Align Vertical Center buttons.

Later you will duplicate this first button to create the other buttons. A centered shape aligns well with other 
duplicate buttons. If the text is centered, button labels with varying numbers of characters will all be well 
aligned.

Relative To Canvas or 
Relative To Object

Align Vertical CenterAlign Horizontal
Center
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18. Click away from the shape and text to deselect them. In the Properties panel, select Over in the State pop-up 
menu (Figure 4).

Figure 4 Properties panel 

19. In the Properties panel, click Copy Up Graphic to copy the Up graphic to the Over button state (Figure 4). 

This saves you time and helps keep the look and position of the button consistent.

20. Decide how you want the button to look when the pointer rolls over the button. Then change the copied graphic 
by modifying the color or effects of the text or the shape.

21. Click away from the shape and text to deselect them. In the Properties panel, select Down in the State pop-up 
menu.

22. Click Copy Over Graphic to copy the Over graphic to this button state.

23. Decide how you want the button to look when visitors click the button. Add effects such as darkening the color.

24. (Optional) You can add a drop shadow to the shape by clicking Add Filters in the Properties panel, and then 
selecting Shadow And Glow > Drop Shadow.

For this project, you will skip the Over While Down state.

25. Click away from the shape and text to deselect them. In the Properties panel, select Active Area in the State pop-
up menu (Figure 4).

The active area of the button is shown by green shading and red lines. This shading indicates the area visitors can 
click to activate the button (Figure 5).

Figure 5 Button Active Area selected 

26. When you are satisfied with the states of your button in the Button Editor, click Page 1 at the top of the screen 
(Figure 6) to close the Button Editor and return to the Page 1 canvas.

Your button appears on the Fireworks Page 1 canvas and in the Document Library panel. 

Figure 6  Fireowrks Button Editor

State pop-up menu
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27. Click the button to select it. In the Link text box in the Properties panel, enter the name of a web page to link to 
this button (Figure 7).

Figure 7 Properties panel with Link text box

28. In the Alt text box, enter an alternative text label for the button.

Alternative text is displayed in place of the image when visitors elect not to display images in their browsers. 
Such text can also be voiced by screen readers for visitors who use them. Typically, alternative text for a button 
should be the same as the text displayed on the button.

29. Select Modify > Canvas > Fit Canvas to fit the canvas to the size of your button.

30. Select File > Save to save the new button.

Copying buttons and making the navigation bar

In the following steps, you duplicate the button you created in the previous steps to make the navigation bar.

To copy the buttons and make the navigation bar:

1. Change the size of the canvas to accommodate all the 
buttons on your navigation bar. Select Modify > Canvas 
> Canvas Size and edit the value for height or width in 
the Canvas Size dialog box.

If you have four buttons, for example, multiply the height 
or width of the first button by four (depending on 
whether your navigation bar is vertical or horizontal).

2. Select the first button. Move it to the top (or to the left 
edge) of the canvas. Select Edit > Clone.

A new instance of the button appears on top of the 
original button.

3. Drag the new button instance below  (or to the right of) 
the original button. You can also use the arrow keys to 
move the button.

4. Repeat steps 2 and 3 as many times as necessary to create 
the rest of your navigation bar (Figure 8). 

5. Click the second button and use the Properties panel to 
edit it. In the Text box, change the text to the name of the 
second button. Edit the information in the Link text box 
and the Alt text box as appropriate for this button.

6. Repeat step 5 for the remaining buttons (Figure 9).

7. To fit the canvas to your navigation bar, select Modify > 
Canvas > Fit Canvas.

8. Save the file.

Figure 8 Cloned buttons

Figure 9 Buttons with edited text labels
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Exporting a navigation bar for use in Dreamweaver

Fireworks enables you to save interactive graphics (a button, for instance) as HTML so you can import working 
buttons into a Dreamweaver document.

To export a navigation bar for use in Dreamweaver:

1. Choose File > Export.

The Export dialog box opens (Figure 10).

2. Navigate to the folder in your local root folder where you 
want to save the navigation bar.

3. Give the navigation bar file a short descriptive name.

4. Make sure the Selected Slices Only option is not selected.

5. Make sure HTML And Images is selected in the Export 
pop-up menu.

6. Make sure the Include Areas Without Slices option is 
selected.

7. Select the Put Images In Subfolder option.

8. Click Save (Windows) or Export (Mac OS).

9. Save the Fireworks document, and close Fireworks.
Figure 10 Export dialog box

Inserting the navigation bar into a Dreamweaver document

Now that you’ve created the navigation bar, you can insert it into a Dreamweaver document. You do so by using an 
option in the Insert panel.

To insert the navigation bar into a Dreamweaver document:

1. Start Dreamweaver.

2. Open the page in which you want to insert the navigation 
bar and save the Dreamweaver document before 
importing.

3. Position the insertion point where you want the 
navigation bar to appear.
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4. In the Common category on the Insert panel, click the 
Images pop-up menu and select Fireworks HTML 
(Figure 11).

The Insert Fireworks HTML dialog box opens 
(Figure 12).

5. In the Insert Fireworks HTML dialog box, click the 
Browse button, and then locate and select your 
navigation bar HTML file. 

6. Click Open.

7. In the Insert Fireworks HTML dialog box, click OK.

The navigation bar appears on the page.

8. To edit a button, select the button and then use the 
Properties panel to change settings, such as the link or 
alternative text.

9. Check that the link address and the alternative text label 
are correct for each button.

10. Save the Dreamweaver document.

11. Select File > Preview In Browser and choose a browser 
from the submenu to test button rollover functions in a 
browser (Figure 13).

Figure 11 Insert panel

Figure 12 Fireworks HTML dialog box

Figure 13 Page previewed in browser
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How to create pop-up menus
Pop-up menus are menus that are displayed in a browser when a site visitor moves the pointer over or clicks a trigger 
image. Items in a pop-up menu can have URL links attached to them for navigation.

You can use pop-up menus to display multiple links within a small space. They provide navigation flexibility without 
long download times. You can define the appearance of the pop-up menu so it matches the overall look and feel of 
your website. A pop-up menu is similar to a table: each menu item is like a table cell. You can customize the menu by 
choosing from a selection of font types, cell colors, and background image styles.

Creating pop-up menus in Fireworks CS6

In the following steps, you will first create entries for a pop-up menu, then set the menu’s appearance and position.

To create entries for a pop-up menu:

1. Start Fireworks CS6.

2. Open or create the image that will trigger the pop-up 
menu.

Note: The trigger image may be a text object or a 
graphic. Be sure to set the canvas dimensions to account 
for the size of the pop-up menu; you can trim the canvas 
after you build the menu to adjust the size.

3. Click the trigger image to select it.

4. Select Edit > Insert > Rectangular Slice to insert a slice 
over the trigger image (Figure 14).

Note: To create a slice that is not rectangular, you can use 
the Polygon Slice tool. See Fireworks Help for more 
information.

When a slice is selected, a circle with cross hairs appears 
in the center of the slice. This is called a behavior handle.

5. Click the behavior handle and select Add Pop-up Menu 
from the context menu (Figure 15).

Figure 14 Sliced image

Figure 15 Behavior handle context menu

Behavior handle
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The Pop-up Menu Editor appears (Figure 16).

6. In the Content tab of the Pop-up Menu Editor, if the 
insertion point is not already in the Text box, click twice 
in that box. Enter the text for a menu item. Click in the 
Link box, and enter the name of the file it links to.

7. To add a new menu item, click the Add Menu (+) button 
and repeat step 6 (Figure 17).

8. To delete a menu item, select the item and click the 
Delete Menu (–) button.

9. After you have entered all the menu items, click Next or 
click the Appearance tab.

Figure 16 Pop-up menu editor

Figure 17 Pop-up Menu Editor with menu entries

Setting the appearance of a pop-up menu

On the Appearance tab of the Pop-up Menu Editor, you can format the text, apply graphic styles to the Over and Up 
states, and select vertical or horizontal orientation for the pop-up menu.

To set the appearance of a pop-up menu:

1. Continue where you left off in the previous task.

2. Select either HTML or Image for Cells (Figure 18).

Note: HTML sets the menu’s appearance using only 
HTML code; this setting produces pages with smaller file 
sizes. Image gives you a selection of graphic image styles 
to use as the cell background; this setting produces pages 
with larger file sizes.

3. Select Vertical Menu or Horizontal Menu from the 
Orientation pop-up menu near the top of the Appearance 
tab.

Settings you choose immediately appear in the preview 
window near the bottom of the Appearance tab.

4. Select font type, font size, and text styles for your menu 
items.

5. Select text and background (Cell) colors for Up State and 
Over State.

These states are similar to button states. The Up state of a 
menu item is its default appearance in the menu. The 
Over state is the appearance of the menu item when the 
pointer passes over it.

Figure 18 Appearance tab of Pop-up Menu Editor

Delete Menu button

Add Menu button
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6. If Image is selected as the cell type, select a graphical 
style for the Up state and the Over state (Figure 19).

7. Click Next or click the Advanced tab (Figure 20) if you 
want to change cell or border attributes.

Typically you can use the default settings in the 
Advanced tab.

Figure 19 Graphical style for cells

Figure 20 Advanced tab of Pop-up Menu Editor

To set the position of a pop-up menu:

1. Continue where you left off in the previous task.

2. Click Next or click the Position tab in the Pop-up Menu 
Editor (Figure 21).

3. Click a Menu Position button to position the pop-up 
menu relative to the trigger slice.

Note: Alternatively, you can enter X and Y coordinates. 
Coordinates of 0, 0 align the upper left corner of the pop-
up menu with the upper left corner of the trigger slice.

4. Click Done. Then save your file.

5. To preview your pop-up menu, select File > Preview In 
Browser and select a browser from the submenu. Figure 21 Position tab of Pop-up Menu Editor
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Editing a pop-up menu

You edit a pop-up menu through the same context menu with which you created the pop-up menu.

To edit a pop-up menu:

1. To edit a pop-up menu, select the slice to which your 
menu is attached and double-click the pop-up menu’s 
blue outline in the workspace, or click the behavior 
handle and select Edit Pop-up Menu (Figure 22).

The Pop-up Menu Editor opens.

2. Set options in the Pop-up Menu Editor just as you did 
when you created your pop-up menu.

Figure 22 Behavior handle context menu

Exporting a pop-up menu for use in Dreamweaver CS6

To save the pop-up menu so it will be active on your website, export the document as HTML.

To export a pop-up menu:

1. While still in Fireworks, trim any excess canvas 
surrounding your image by choosing Modify > Canvas > 
Trim Canvas.

2. Save the file.

3. Select File > Export.

The Export dialog box opens.

4. Navigate to your local root folder.

5. Give the pop-up menu a short, descriptive name.

6. Select HTML And Images in the Export menu.

7. Make sure the option Put Images In Subfolder is selected.

Note: Putting all the exported image files in a subfolder 
is a good way to manage those files.

8. Save (Windows) or Export (Mac OS).

9. Save your document and close Fireworks.

Importing a pop-up menu into Dreamweaver

You insert a pop-up menu into Dreamweaver as you would anything else, by using the Insert panel.

To insert a pop-up menu into Dreamweaver:

1. Start Dreamweaver.
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2. Open the document into which you want to import the 
pop-up menu.

3. Position the insertion point where you want the pop-up 
menu to appear. You can also place the pop-up menu 
within a div for more precise positioning of the menu.

4. Make sure the Common category is selected in the Insert 
panel. Click the down arrow on the Images button, and 
select Fireworks HTML (Figure 23).

The Insert Fireworks HTML dialog box opens 
(Figure 24).

5. Click Browse, select the pop-up menu HTML file, and 
click Open.

Note: The Images subfolder contains the sliced images 
for your pop-up menu.

6. OK to close the Insert Fireworks HTML dialog box.

The pop-up menu is inserted into your Dreamweaver 
document.

7. Save your Dreamweaver document. 

8. Select File > Preview In Browser and select a browser 
from the submenu to test the menu and the links for the 
menu items (Figure 25).

Figure 23 Insert panel

Figure 24 Fireworks HTML dialog box

Figure 25 Testing a pop-up menu

How to create rollover images
A rollover is an image that changes when the pointer moves across it. A rollover actually consists of two images: the 
primary image (the image displayed when the page first loads) and the rollover image (the image that appears when 
the pointer moves over the primary image).

Rollover images add highlighting or design effects by drawing viewer attention when the images are swapped. One 
example is a button that highlights or changes color when the pointer passes over it.

Creating a rollover image

You create a rollover image by inserting it from the Insert panel and then setting options in the Insert Rollover Image 
dialog box.

To create a rollover image:

1. Open Dreamweaver CS6 and open the document in 
which you want to create a rollover image.
© 2012 Adobe Systems Incorporated How to create interactive navigation 11
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2. Make sure the Common category is selected in the Insert 
panel. Click the down arrow on the Images button and 
select Rollover Image from the pop-up menu 
(Figure 26).

The Insert Rollover Image dialog box opens (Figure 27).

3. Use the Insert Rollover Image dialog box to set up your 
rollover:

• Image Name: Type a name for the rollover image.

• Original Image: Click Browse and select the image 
to be displayed when the page loads.

• Rollover Image: Click Browse and select the image 
to be displayed when the pointer rolls over the 
original image.

• Alternate Text: Type the text you want to appear as 
alternate text for the image.

• When Clicked, Go To URL: Click Browse and select 
the file (or type the path to the file) to be opened 
when the image is clicked.

4. Click OK to close the dialog box.

5. Save the page.

6. Select File > Preview In Browser and select a browser 
from the submenu to preview the rollover image and test 
the link.

Figure 26 Insert panel

Figure 27 Insert Rollover Image dialog box

Figure 28 Testing a rollover image: up (top) and 
over (bottom)
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Developing interactive buttons using CSS
As CSS3 gains wider support in modern devices and browsers, design elements such as interactive buttons can now 
be constructed entirely in CSS. Advanced users may prefer to create CSS-based buttons from a Fireworks design. 
You can use the CSS Properties panel to extract a design object’s properties (rounded corners, opacity, and more) and 
map the properites to HTML elements by using CSS in Dreamweaver. 

In this section, you use Fireworks and Dreaweaver to build a simple set of CSS-based navigation buttons. Fireworks 
is used to create a shape, add text, and add a drop-shadow effect. Use the CSS Properties panel to extract the shape’s 
design elements, and add them to an HTML element in Dreamweaver.

Visit the Adobe Developer Center at www.adobe.com/devnet.html to learn more about how to extend and refine your 
CSS-based interactive navigation.

To create CSS-based interactive buttons:

1. Create a new document in Fireworks and make it 200 
pixels by 200 pixels, and set the Resolution to 72 pixels/
inch.

2. Use the Rectangle tool or the Ellipse tool from the Tools 
panel to draw a shape for the button. Make the 
dimensions of the shape fit the size of your navigation 
bar.

3. Use the Gradient Fill button to add a Gradient Shape and 
set fill colors.

4. Use the Properties panel to add color and gradient to the 
button.

5. Use the Text tool to add text to the button. 

6. Use the Smart Guides to center the text over the button 
shape.

In Figure 29, the sample button is a 145x35 pixel 
rounded rectangle with a red radial gradient. Text is 
Verdana, Bold, with font size set to 15 and color set to 
white. 

7. Choose the Pointer tool from the Tools panel and select 
the button shape on the canvas.

8. Select Window >  CSS Properties.

The CSS Properties panel opens and displays the list of 
CSS properties for the selected object (Figure 30).

You will return to the CSS Properties panel after the 
HTML elements have been created in Dreamweaver. 

9. Start Dreamweaver and select File > New.

10. In the New Document dialog box, select Blank Page, 
select HTML for Page tyep, and select <none> for 
Layout. Click Create.

Figure 29 Sample Fireworks button design

Figure 30 CSS Properties panel 

Copy All button
© 2012 Adobe Systems Incorporated How to create interactive navigation 13



Project 3 guide Adobe Fireworks CS6 and Adobe Dreamweaver 

14
11. Save the new document.

12. Click the Split button in the Document toolbar 
(Figure 31).

Code view and Design view are visible in the document 
window.

You will work in Code view in the next steps. 

13. In Code view, locate the <body> tag, place the insertion 
point at the end of the opening <body> tag, and press 
Enter (Windows) or Return (Mac OS).

Figure 31 Dreamweaver Document toolbar

14. Enter (or copy and paste) the following code between the <body> tags in the Code view. If you enter the code 
directly from the keyboard, watch for code hints as you type. You can save work by double-clicking the code 
pieces you need from the lists that appear.
<ul>
   <li class="button"><a href="#">Home</a></li>
</ul>

15. Copy the complete list item Home code inside the <ul> tags and paste it three times before the closing </ul> 
tag (Figure 32).

Figure 32 Sample code

16. Replace "Home" in the three copies with "Directions", "Hours", and "Facilities", respectively (Figure 33).

This code creates an unordered list, that is associated with a button class that is not yet defined. Each list item is 
a link.

Figure 33 Sample code

17. Open the CSS Styles panel (Window > CSS Styles). If a message reminds you that you've made coding changes, 
click the Refresh button in the CSS Styles panel.
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18. In the CSS Styles panel, click the New CSS Rule button 
(Figure 34). 

The New CSS Rule dialog box opens (Figure 35).

19. Open the Selector Type menu and select Class (Can 
Apply To Any HTML Element).

20. Type .button in the Selector Name text box. 

21. Click OK to close the New CSS Rule dialog box.

The CSS Rule Definition dialog box opens.

22. Click OK to close the CSS Rule Definition dialog box 
without setting any style options. 

You will use content from the Fireworks CSS Properties 
panel to apply style options to the new empty button rule.

23. Return to Fireworks and open the CSS Properties panel.

24. Select the button shape and click the Copy All button 
(Figure 30).

The CSS properties for the graphic are extracted and 
saved to the clipboard.

25. Switch to Dreamweaver.

26. In Code view, locate the <style> tag in the head section, 
place the insertion point between the open and closing 
curly brackets that follow the .button selector,  and press 
Enter (Windows) or Return (Mac OS).

27. Select Edit > Paste to insert the saved CSS properties into 
the button selector.

28. Click in the Design view to refresh.

The background of the list items in Design view changes. 

29. Click the Live button in the Document toolbar at the top 
of the Document window to preview the initial changes 
to the button list (Figure 36).

The button design still needs a bit of refinement.

30. Switch to Fireworks, select the button text, and click the 
Copy All button in the CSS Properties panel.

31. Return to Dreamweaver, locate the closing curly bracket 
of the button selector, and paste the contents of the 
clipboard inside the bracket.

32. In Code view, enter in the following code at the end of 
the button selector declaration:
list-style: none;
This removes the default list marker.

Figure 34 CSS Styles panel

Figure 35 New CSS Rule dialog box

Figure 36 Shape attributes applied to list items

New CSS Rule

Selector text box Selector Type menu
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33. Click in the Design view to refresh.

Notice the CSS styles are applied to the text in the Design 
view (Figure 37). However, the link text has assumed the 
default color for link attributes. This can be easily fixed 
by redefining the link attribute CSS style. 

Figure 37 Text attributes applied to list items

34. Enter (or copy and paste) the following code between the .button closing curly bracket, and the closing </
style> tag (Figure 38):
a:link {color: #ffffff; text-decoration:none;}
a:hover, a:active, a:focus {text-decoration: underline;}
a:visited {color: #ffffff;}

Figure 38 Sample code

35. Click in the Design view to refresh.

The link attributes are applied to the list items 
(Figure 39).

36. Test the items in the Live view to see how the text 
becomes underlined when the mouse hovers over a link.

The other selectors proviede a keyboard navigator the 
same hover experience as the person using a mouse.

The list item buttons remain close together.  

37. In Code view, place the insertion point after list-
style:none; at the end of the .button selector 
definition, and press Enter (Windows) or Return (Mac 
OS).

A list of code hints appears. As you type characters in 
Code view, you will see a list of candidates that 
automatically complete your entry.

38. Type marg. A list of options appears (Figure 40).

39. Double-click margin-top from the list of available 
options.

40. Type 10px;. 

The top margin for the list item is now set to 10 pixels. 
The semicolon closes the property-value pair.

Figure 39 Link attributes applied to list items

Figure 40 Code hints
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41. Click in the Design view.

The list item buttons are now separated by 10 pixels that's 
been added to the top margin of each button (Figure 41).

42. Select File > Preview In Browser, and then select a 
browser to preview the interactive CSS buttons in a web 
browser (Figure 42).

Figure 41 Margin attribute applied to list items

Figure 42 Test buttons in web browser
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